ChargeOver outage

Incident Report for ChargeOver

Resolved

ChargeOver was inaccessible for most users from approximately 9:44am CT to 9:58am CT, due to a database connection issue.

No data loss occurred. Scheduled subscription invoice creation and payment processing were not affected - all scheduled payments processed normally.

We are still investigating root cause. A postmortem will follow.
Posted Oct 28, 2025 - 10:04 CDT

Monitoring

ChargeOver is accessible again.

We are investigating root cause and investigating the outage.
Posted Oct 28, 2025 - 09:55 CDT

Investigating

ChargeOver is down for some users.

We are investigating.
Posted Oct 28, 2025 - 09:51 CDT
This incident affected: Main Application, Email Sending, Payment Processing, and Integrations.