Network provider outage

Incident Report for ChargeOver

Resolved

Connectivity issues have been resolved.

Some payments may need to be re-attempted. Some syncs to external platforms (QuickBooks, Xero, Salesforce, etc.) may need re-sync.
Posted Apr 14, 2026 - 07:45 CDT

Monitoring

We are continuing to monitor connectivity, and await an update from our primary data center (Flexential).

ChargeOver is operating normally at this time.

Some payments may need to be re-attempted. Some syncs to external platforms (QuickBooks, Xero, Salesforce, etc.) may be delayed or need re-sync.
Posted Apr 14, 2026 - 05:50 CDT

Update

ChargeOver is accessible again. Flexential has restored network connectivity to our data center and we are actively monitoring performance and stability. We have not yet received an official all-clear from Flexential.

We will post a final update once we have confirmed full resolution.
Posted Apr 14, 2026 - 03:59 CDT

Update

No change in status. This continues to be a network connectivity issue upstream of our infrastructure.

Next update in 60 minutes or sooner if status changes.
Posted Apr 14, 2026 - 03:00 CDT

Update

Progress has been made in identifying the cause. Flexential's carrier vendor has isolated a faulty optical component on the affected circuit and a technician is en route to replace it. No restoration ETA has been provided yet.

This continues to be a network connectivity issue upstream of our infrastructure.

Next update in 60 minutes or sooner if status changes.
Posted Apr 14, 2026 - 01:48 CDT

Update

No change in status. Flexential has confirmed that carrier circuits at their Chaska, MN facility remain down. Their network engineers are engaged with the carrier vendor, who is actively investigating. No restoration ETA has been provided.

Our systems remain online and operational. This continues to be a network connectivity issue upstream of our infrastructure.

Next update in 60 minutes or sooner if status changes.
Posted Apr 14, 2026 - 00:58 CDT

Investigating

ChargeOver is currently unreachable. Our upstream network provider is experiencing an outage affecting connectivity to our data center. Our systems are online and operational; this is a network issue outside of our infrastructure.

Our provider is aware of the issue and is actively working toward a resolution. We do not have an ETA at this time.

We will post an update every 60 minutes until this is resolved.
Posted Apr 13, 2026 - 23:46 CDT
This incident affected: Main Application.