ChargeOver is inaccessible

Incident Report for ChargeOver

Resolved

This incident has been resolved, and all services are functioning normally now.

A postmortem will follow.
Posted Aug 01, 2026 - 09:58 CDT

Update

We are continuing to monitor for any further issues.

Automated processes (creating invoices; running payments; syncing to QuickBooks/Xero/Salesforce) continue to catch up.
Posted Aug 01, 2026 - 05:44 CDT

Update

We are continuing to monitor for any further issues.
Posted Aug 01, 2026 - 04:46 CDT

Monitoring

ChargeOver service has been restored.

Automated invoice generation, and automated payment processing is delayed, but will catch up rapidly and will not require any manual action by merchants. Sync of data to other platforms (QuickBooks, Xero, Salesforce) will be delayed, but will catch up rapidly, and will not require any manual re-sync.

More updates and a postmortem will be posted later.
Posted Aug 01, 2026 - 04:45 CDT

Identified

ChargeOver is currently inaccessible.

We are working on a resolution ASAP.
Posted Aug 01, 2026 - 01:24 CDT
This incident affected: Main Application.