Delayed sync of data to QuickBooks Online, Xero, and Salesforce for approximately 30% of accounts

Incident Report for ChargeOver

Resolved

Syncing for all affected integrations is complete now.

A postmortem will follow.
Posted Oct 30, 2025 - 14:34 CDT

Monitoring

Syncing has completely caught up for all but approximately 10% of ChargeOver accounts.

The remaining ChargeOver accounts continue to catch up quickly, but are still delayed.

We are continuing to monitor the situation, and a postmortem will follow.
Posted Oct 30, 2025 - 09:17 CDT

Identified

We have identified a component failure which is delaying the sync of data to some systems for approximately 30% of ChargeOver accounts.

The affected integrations are:
* QuickBooks Online
* Xero
* Salesforce

Syncing will catch up automatically, but may be delayed.

We are still investigating root cause and will follow up with a postmortem.
Posted Oct 30, 2025 - 08:41 CDT
This incident affected: Integrations.