Emails failing to send with a "Invalid handle provided" error message

Incident Report for ChargeOver

Resolved

This incident has been resolved.

A postmortem will follow.
Posted Nov 11, 2025 - 14:12 CST

Update

We are continuing to monitor for any further issues.
Posted Nov 11, 2025 - 13:35 CST

Monitoring

This issue should be resolved now. We are monitoring this for any further action.

A postmortem will follow.
Posted Nov 11, 2025 - 13:35 CST

Identified

We have identified the problem, and are expecting a resolution within the next 30 minutes.

We will provide an update here again shortly.
Posted Nov 11, 2025 - 13:10 CST

Investigating

We are currently investigating this issue.

Some emails are not sending, instead triggering a "Invalid handle provided" message.

Payment processing and integrations are unaffected.
Posted Nov 11, 2025 - 12:21 CST
This incident affected: Email Sending.