First Data / Payeezy is experiencing a widespread network outage
Incident Report for ChargeOver
Resolved
First Data has informed us that the problem is resolved.

First Data has not provided a root cause or any other information about the issue at this time.
Posted Sep 02, 2020 - 18:58 CDT
Update
The ChargeOver team is continuing to monitor this situation. First Data has not yet provided an ETA or status update. They are aware of the issue and are working to resolve it.

As we get more information from First Data, we will provide further updates.
Posted Sep 02, 2020 - 18:41 CDT
Update
We continue to monitor this situation. First Data has not responded to our team with an ETA or status update at this time, but we are seeing much better connectivity and much improved processing with First Data now.

As we get more information from First Data, we will provide further updates.
Posted Sep 02, 2020 - 15:29 CDT
Monitoring
First Data (Payeezy, BluePay, and a backend to many other payment processors) is currently experiencing a network outage.

Merchants using Payeezy as a payment processor may see sporadic gateway timeouts / connection errors / other errors until First Data resolves this issue.

First Data was unable to give us an ETA at this time, but as we get more information from them, we will provide updates.
Posted Sep 02, 2020 - 12:09 CDT
This incident affected: Payment Processing.