ChargeOver unavailable for some users

Incident Report for ChargeOver

Resolved

This has been resolved.

We are investigating what occurred here still. A postmortem will follow.
Posted Mar 26, 2026 - 12:18 CDT

Investigating

We are investigating the issue.

We are expecting to have this resolved within the next 30 minutes.
Posted Mar 26, 2026 - 11:57 CDT
This incident affected: Main Application and Payment Processing.